summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMantas Mikulėnas2020-11-18 10:16:02 +0200
committerMantas Mikulėnas2020-11-18 10:16:02 +0200
commite19093c9fef2edbb874458d0ee27bb028bfbbedf (patch)
tree26eb87c0da27eaf629c8769211b2b8d036b844cf /PKGBUILD
parent693e7154c2484161584dc91cb632ac802fbd5af9 (diff)
downloadaur-e19093c9fef2edbb874458d0ee27bb028bfbbedf.tar.gz
download LICENSE file from repository
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a7362957747d..8a6efc60f876 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,17 @@
_name=ocspbuilder
pkgname=python-ocspbuilder
pkgver=0.10.2
-pkgrel=1
+pkgrel=2
pkgdesc="Python library for generating OCSP requests and responses"
url="https://github.com/wbond/ocspbuilder"
arch=(any)
license=(custom:MIT)
depends=(python python-asn1crypto python-oscrypto)
makedepends=(python-setuptools)
-source=("https://pypi.python.org/packages/source/${_name:0:1}/${_name}/${_name}-${pkgver}.tar.gz")
-sha256sums=("945629537ac6d6960a7413fd32fc49448a442f9dfd87f6de5c239e89ed853a0d")
+source=("https://pypi.python.org/packages/source/${_name:0:1}/${_name}/${_name}-${pkgver}.tar.gz"
+ "$pkgname-$pkgver-LICENSE::https://raw.githubusercontent.com/wbond/${_name}/${pkgver}/LICENSE")
+sha256sums=("945629537ac6d6960a7413fd32fc49448a442f9dfd87f6de5c239e89ed853a0d"
+ '3ef40aca4f8f13ab0431c203148085a228c85ec64f30d6a06438f304552e958f')
build() {
cd $_name-$pkgver
@@ -20,6 +22,7 @@ build() {
package() {
cd $_name-$pkgver
python setup.py install -O1 --skip-build --root="$pkgdir"
+ install -Dm644 ../$pkgname-$pkgver-LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt"
}
# vim:set ts=2 sw=2 et: