summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorlilac2019-07-09 20:39:26 +0800
committerlilac2019-07-09 20:39:26 +0800
commitc53d7b574a66b044730bfd00b8caa644d4246333 (patch)
treec8e826b612b698c2ebf7e4966757e4eaa746559b /PKGBUILD
parent031aa408ada648cf1ad0dc2323ead24100a7d0f7 (diff)
downloadaur-c53d7b574a66b044730bfd00b8caa644d4246333.tar.gz
update by lilac
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bc322d4d79f4..9033f5387706 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,17 @@
pkgname=python-onnx
pkgver=1.5.0
-pkgrel=2
+pkgrel=4
pkgdesc='Open Neural Network Exchange'
arch=('x86_64')
url='https://onnx.ai'
license=('MIT')
depends=(
'protobuf'
+ 'python-protobuf'
'python-numpy'
'python-six'
+ 'python-typing_extensions'
)
makedepends=(
'cmake'
@@ -29,12 +31,15 @@ optdepends=(
'python-pytorch'
'python-tensorflow'
)
-source=("${pkgname}::git+https://github.com/onnx/onnx.git#tag=v${pkgver}")
-sha512sums=('SKIP')
+source=("${pkgname}::git+https://github.com/onnx/onnx.git#tag=v${pkgver}"
+ 'no-typing.patch')
+sha512sums=('SKIP'
+ '902df9eb236f69c47d838813687fa8f22fee0efeea6a831a9ed0c78c8f52d93e31c57689141c92a8eb1a4c3592a8e01162c857b72766543a9e1a8f43b1b0efe7')
prepare() {
cd "${srcdir}/${pkgname}"
git submodule update --init --recursive
+ patch -Np1 -i ../no-typing.patch
}
build() {
@@ -44,7 +49,7 @@ build() {
check() {
cd "${srcdir}/${pkgname}"
- pytest -v
+ PYTHONPATH=$(pwd)/build/lib.linux-$CARCH-3.7 pytest -v
}
package() {