summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichael Serpieri2018-01-08 21:39:44 -0500
committerMichael Serpieri2018-01-08 21:39:44 -0500
commita51adbb37fcc249ed67b1f237665e1052812597c (patch)
tree4e4f034780347a18f7315ca3988eb170eff5e25f /PKGBUILD
downloadaur-a51adbb37fcc249ed67b1f237665e1052812597c.tar.gz
1.0.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..995d291692a9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: mickybart <mickybart at pygoscelis dot org>
+
+pkgname=('python-openbrokerapi')
+pkgver='1.0.0'
+pkgrel=1
+pkgdesc="A python package for the V2 CF Service Broker API and Open Broker API (version 2.13+)"
+url="https://github.com/eruvanos/openbrokerapi"
+depends=('python' 'python-flask')
+makedepends=('python-setuptools')
+license=('MIT')
+arch=('any')
+source=("${pkgname}::git+https://github.com/eruvanos/openbrokerapi#tag=v${pkgver}"
+ 'LICENSE')
+md5sums=('SKIP'
+ '01fd3820ef015cfa1c6143d706106489')
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ python setup.py build
+}
+
+package() {
+ depends+=()
+ cd "${srcdir}/${pkgname}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+
+ # license
+ install -Dm644 "${srcdir}/LICENSE" "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+