summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorShiv Upadhyay2019-04-09 22:19:38 -0400
committerShiv Upadhyay2019-04-09 22:19:38 -0400
commitde31b46f542c699ec0d06dc67dbcf7df985e0b3a (patch)
tree249273d123e38d0ff8f94c893c293c14c0b9ea2b /PKGBUILD
downloadaur-de31b46f542c699ec0d06dc67dbcf7df985e0b3a.tar.gz
Creating openchemistrypy PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..58b08b7c1185
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+pkgname=('python-openchemistrypy-git')
+_srcname='openchemistrypy'
+pkgdesc='OpenChemistry python libraries.'
+pkgver=0.0.17
+pkgrel=1
+arch=('any')
+url="https://github.com/OpenChemistry/${_srcname}"
+license=('BSD 3-Clause')
+
+depends=('python' 'avogadro2-git')
+makedepends=('git' 'python-setuptools')
+provides=("${pkgname[0]%-git}")
+conflicts=("${pkgname[0]%-git}")
+
+source=("${_srcname}::git+${url}.git")
+sha512sums=('SKIP')
+
+package() {
+ cd "${srcdir}/${_srcname}"
+
+ python setup.py install --root="${pkgdir}" --optimize=1
+}