summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJameson Pugh2018-04-09 14:16:37 -0400
committerJameson Pugh2018-04-09 14:16:37 -0400
commit08999e913dfd49438972956dbbbbac976f561317 (patch)
tree95a23cabf97424ee547155f4c37fd63ef70779cd /PKGBUILD
downloadaur-08999e913dfd49438972956dbbbbac976f561317.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..be6a1aa46986
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Jameson Pugh <imntreal@gmail.com>
+
+pkgbase=python-openid-cla
+pkgname=('python-openid-cla' 'python2-openid-cla')
+pkgver=1.2
+pkgrel=1
+pkgdesc='CLA extension for python-openid'
+arch=(any)
+url='https://github.com/puiterwijk/python-openid-cla/'
+license=(BSD)
+makedeps=('python-setuptools' 'python2-setuptools')
+source=("https://github.com/puiterwijk/python-openid-cla/archive/v${pkgver}.tar.gz")
+sha256sums=('1ca811f26cc4609b3d2a283c526732e6a75cc9f4f0e43039518e244d7f8939a2')
+
+package_python-openid-cla() {
+ pkgdesc='Utilities used around Fedora Infrastructure to send and receive messages (Python 3 version)'
+ depends=('python-openid')
+ cd "python-openid-cla-${pkgver}"
+
+ python setup.py install --root="${pkgdir}" --optimize=1
+}
+
+package_python2-openid-cla() {
+ pkgdesc='Utilities used around Fedora Infrastructure to send and receive messages (Python 2 version)'
+ depends=('python2-openid')
+ cd "python-openid-cla-${pkgver}"
+
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: