summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuis Martinez2022-03-01 13:33:49 -0600
committerLuis Martinez2022-03-01 13:33:49 -0600
commitac67559152a359f6bbaf41b8b6529cfaaff236ce (patch)
tree0f9b55d89c250191d941aa201fafe647534919b1 /PKGBUILD
parent2cde13a3dcaced277209775dd113a2badb0a1238 (diff)
downloadaur-python-openshift.tar.gz
use python-installer for packaging
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c76c89126ace..65023d8c1ba1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=python-openshift
pkgver=0.13.1
-pkgrel=1
+pkgrel=2
pkgdesc="Python client for the OpenShift API"
arch=('any')
url="https://github.com/openshift/openshift-restclient-python"
@@ -17,14 +17,14 @@ depends=(
'python-six'
'python-requests'
'python-requests-oauthlib')
-makedepends=('python-setuptools' 'python-build' 'python-install' 'python-wheel')
+makedepends=('python-setuptools' 'python-build' 'python-installer' 'python-wheel')
checkdepends=('python-pytest')
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
sha256sums=('6a061cc12247e96147e40d8463c133cb01b915907af10df08d937d27e6a1f283')
build() {
cd "openshift-restclient-python-$pkgver"
- python -m build --wheel --skip-dependency-check --no-isolation
+ python -m build --wheel --no-isolation
}
check() {
@@ -33,6 +33,7 @@ check() {
}
package() {
+ export PYTHONHASHSEED=0
cd "openshift-restclient-python-$pkgver"
- python -m install --optimize=1 --destdir="$pkgdir/" dist/*.whl
+ python -m installer --destdir="$pkgdir/" dist/*.whl
}