summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authora8212023-05-15 21:45:16 +0200
committera8212023-05-15 21:48:50 +0200
commit977540c2d24c7c518f3c114bcef73a23634221a0 (patch)
tree1972b5abdff12b0db13349f101c5afe89d6e20f3 /PKGBUILD
parent0a23fe922d9e29a457ccc56e9a82f72562583660 (diff)
downloadaur-977540c2d24c7c518f3c114bcef73a23634221a0.tar.gz
Fix PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 21 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ab85d3016efa..e03c63889d7f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,39 @@
+# Maintainer: a821
# Contributor: Alexandr Parkhomenko <it@52tour.ru>
-_author=pavlin-policar
-_pkgname=opentsne
-pkgname=python-$_pkgname-git
-pkgver=0.5.1
+pkgname=python-opentsne-git
+pkgver=0.7.1.r0.ga46fae0
pkgrel=1
pkgdesc="Extensible, parallel implementations of t-SNE"
url="https://opentsne.readthedocs.io/en/latest/"
arch=('x86_64')
license=('BSD')
-depends=('fftw' 'python-scikit-learn' 'python-numba')
-makedepends=('python-setuptools')
-source=("git://github.com/$_author/$_pkgname")
+depends=('fftw' 'python-scikit-learn')
+makedepends=('cython' 'git' 'python-setuptools' 'python-build' 'python-installer' 'python-wheel')
+optdepends=(
+ 'python-pynndescent: for nearest neighbor descent search'
+ 'python-hnswlib: for fast approximate nearest neightbors'
+)
+source=("git+https://github.com/pavlin-policar/openTSNE.git")
sha256sums=('SKIP')
pkgver () {
- cd "$srcdir/$_pkgname"
- git describe --tags `git rev-list --tags --max-count=1` | sed -r 's/^v//;s/-RC/RC/;s/([^-]*-g)/r\1/;s/-/./g' #| sed -r "s/0$/$COMMIT/"
+ cd "openTSNE"
+ git describe --long --tags | sed 's/^v//;s/-/.r/;s/-/./g'
}
+prepare() {
+ cd "openTSNE"
+ sed -i 's/oldest-supported-//' pyproject.toml
+}
build() {
- cd "${srcdir}/$_pkgname"
- python setup.py build
+ cd "openTSNE"
+ python -m build --wheel --no-isolation
}
package() {
- cd "${srcdir}/$_pkgname"
- python setup.py install --root=${pkgdir} --optimize=1
+ cd "openTSNE"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}