summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichel Zou2017-05-15 22:35:13 +0200
committerMichel Zou2017-05-15 22:35:13 +0200
commitc2569b8fa4cb8909d94462b126d98c184443108a (patch)
treee2681e258c30c64117a35bf048da585d0ce22be4 /PKGBUILD
parent497af7fe8c58b039328ea4042e9d8ab820437eeb (diff)
downloadaur-c2569b8fa4cb8909d94462b126d98c184443108a.tar.gz
3.4.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6a17285eecf9..f18a8d14d809 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=python-orange
-pkgver=3.3.11
-pkgrel=3
+pkgver=3.4.2
+pkgrel=1
pkgdesc="Open source data visualization and analysis for novice and experts. Data mining through visual programming or Python scripting."
arch=('i686' 'x86_64')
url="http://orange.biolab.si/"
@@ -8,7 +8,8 @@ license=('GPL3')
makedepends=('python-setuptools')
depends=('python-beautifulsoup4' 'python-chardet' 'python-docutils' 'python-pyqtgraph' 'python-xlrd' 'python-matplotlib' 'python-scikit-learn' 'python-recommonmark' 'python-sqlparse' 'python-psycopg2' 'python-bottlechest' 'python-joblib' 'python-keyrings-alt' 'python-bottleneck' 'python-anyqt' 'python-dill' 'python-pip')
source=("https://github.com/biolab/orange3/archive/${pkgver}.tar.gz")
-sha1sums=('bc1f337e1abc1a7d719d561d80f6fbe13f7fe634')
+sha1sums=('95389bea0d555f9d5dc84719840350945fc8575b')
+
build() {
cd "${srcdir}/orange3-$pkgver"
@@ -17,7 +18,7 @@ build() {
package() {
cd "${srcdir}/orange3-$pkgver"
- python setup.py install --root="${pkgdir}"
+ python setup.py install --root="${pkgdir}" --optimize=1
install -Dm644 distribute/orange-canvas.desktop "${pkgdir}"/usr/share/applications/orange-canvas.desktop
install -Dm644 distribute/icon-256.png "${pkgdir}"/usr/share/icons/hicolor/256x256/apps/orange-canvas.png
}