summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexandrParkhomenko2020-03-21 22:37:00 +0300
committerAlexandrParkhomenko2020-03-21 22:37:00 +0300
commita8ce71e4945c586a80293a54c00a26307b2333ac (patch)
treed8dc630c86aa686a3987eddd9cd1a4f40523d8fb /PKGBUILD
downloadaur-a8ce71e4945c586a80293a54c00a26307b2333ac.tar.gz
welcome
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3c8d0f56378b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Contributor: Alexandr Parkhomenko <it@52tour.ru>
+
+pkgname=python-orange-canvas-core
+pkgver=0.1.11
+pkgrel=1
+pkgdesc="Orange Canvas core workflow editor."
+arch=('i686' 'x86_64')
+url="http://orange.biolab.si/"
+license=('GPL3')
+makedepends=('python-setuptools')
+depends=('python-chardet' 'python-docutils' 'python-pyqtgraph' 'python-xlrd' 'python-matplotlib' 'python-scikit-learn' 'python-psycopg2' 'python-joblib' 'python-keyrings-alt' 'python-bottleneck' 'python-anyqt' 'qt5-svg' 'python-pip' 'python-serverfiles' 'python-louvain' 'python-xlsxwriter' 'python-opentsne' 'python-networkx' 'python-requests' 'python-pandas')
+source=("https://github.com/biolab/orange-canvas-core/archive/v${pkgver}.tar.gz")
+sha256sums=('SKIP')
+
+build() {
+ cd "${srcdir}/orange-canvas-core-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/orange-canvas-core-$pkgver"
+ python setup.py install --root="${pkgdir}" --optimize=1
+}
+