summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoaquim Monteiro2020-01-23 18:17:16 +0000
committerJoaquim Monteiro2020-01-23 18:17:16 +0000
commitc7181444e8797dca826f7e1b90e1e47cf59e31bd (patch)
tree880e1b79e7530952f042127979466c5f36ac5604 /PKGBUILD
downloadaur-c7181444e8797dca826f7e1b90e1e47cf59e31bd.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e123af9e462f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: gmes78 <gmes.078 at gmail dot com>
+
+# NOTE: building this package requires a nightly build of the Rust compiler.
+
+pkgname=python-orjson-git
+pkgver=2.2.0.r0.g95a03b0
+pkgrel=1
+pkgdesc="Fast, correct Python JSON library supporting dataclasses and datetimes (Git version)"
+arch=(x86_64 i686)
+url="https://github.com/ijl/orjson"
+license=('Apache' 'MIT')
+
+provides=('python-orjson')
+conflicts=('python-orjson')
+
+depends=('python')
+makedepends=('git' 'python-pip' 'rust')
+
+source=("git+https://github.com/ijl/orjson.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd orjson
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd orjson
+ rm -f "./*.whl" # remove old wheels
+
+ PIP_CONFIG_FILE=/dev/null pip wheel --isolated --no-binary=orjson .
+}
+
+package() {
+ cd orjson
+ PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps ./*.whl
+ install -Dm644 LICENSE-MIT "$pkgdir/usr/share/licenses/$pkgname/LICENSE-MIT"
+}