summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFeakster2021-01-21 00:01:23 +0000
committerFeakster2021-01-21 00:01:23 +0000
commita3cc90dfe9a3c92be25e6735b0655c973a505f62 (patch)
treea2e014eb7e8584501f46d2332ec0039e1f0d422e /PKGBUILD
downloadaur-a3cc90dfe9a3c92be25e6735b0655c973a505f62.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD57
1 files changed, 57 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3fc4fa532f57
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# Maintainer: Feakster <feakster at posteo dot eu>
+
+### Notes ###
+# - Repo: 'https://github.com/physimals/oxasl'
+# - Docs: 'https://oxasl.readthedocs.io/en/latest/'
+
+### Info ###
+pkgname=python-oxasl
+_pkgname=${pkgname/python-/}
+pkgver=0.1.12
+pkgrel=1
+pkgdesc='OXASL is a package for performing Bayesian analysis of Arterial Spin Labelling MRI data'
+arch=('any')
+url='https://oxasl.readthedocs.io'
+license=('custom:OXASL license')
+depends=('fslpy>=1.13' 'python' 'python-numpy' 'python-pandas' 'python-pyaml' 'python-pyfab' 'python-nibabel' 'python-scikit-image' 'python-six')
+makedepends=('git' 'python-setuptools')
+checkdepends=('python-pytest')
+source=("$pkgname::git+https://github.com/physimals/${_pkgname}.git#tag=v$pkgver")
+b2sums=('SKIP')
+
+### Build ###
+build() {
+ ## Change Directory ##
+ cd "$srcdir/$pkgname"
+
+ ## Build ##
+ python setup.py build
+}
+
+### Check ###
+check() {
+ ## Change Directory ##
+ cd "$srcdir/$pkgname"
+
+ ## Test ##
+ pytest
+}
+
+### Package ###
+package() {
+ ## Change Directory ##
+ cd "$srcdir/$pkgname"
+
+ ## Install Package ##
+ python setup.py install \
+ --prefix=/usr \
+ --root="$pkgdir"/ \
+ --optimize=1 \
+ --skip-build
+
+ ## Install License ##
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+
+ ## Install Docs ##
+ install -Dm644 README.md "$pkgdir"/usr/share/doc/$pkgname/README.md
+}