summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoreugene2023-05-27 19:52:55 +0000
committereugene2023-05-27 19:52:55 +0000
commit8c3e8149f7c8a2aaafa310bd704a1aef581cd549 (patch)
treef019484d936e222e6e5426632432fa2ec7461191 /PKGBUILD
parente9d4a95ffc79359651e699f1511f4d458762c184 (diff)
downloadaur-8c3e8149f7c8a2aaafa310bd704a1aef581cd549.tar.gz
update to 1.4.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 22 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c3fb610489cc..c1b2cf865ade 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,34 @@
-# Maintainer: Steven Allen <steven@stebalien.com>
+# Contributor: Steven Allen <steven@stebalien.com>
# Contributer: Felix Yan <felixonmars@gmail.com>
# Contributor: Max Meyer <dev@fedux.org>
-pkgname='python-pacparser'
-pkgver=1.4.0
-pkgrel=2
-arch=(i686 x86_64)
-url="https://github.com/manugarg/pacparser"
-license=('LGPL')
+pkgname=python-pacparser
+pkgver=1.4.2
+pkgrel=1
+pkgdesc='Python 3.x pacparser module'
+arch=(i686 x86_64 aarch64)
+license=(LGPL)
+url=https://github.com/manugarg/pacparser
depends=('python>=3.7')
-options=('!makeflags')
-pkgdesc="Python 3.x pacparser module"
-source=("${url}/releases/download/v${pkgver}/pacparser-v${pkgver}.tar.gz")
-sha256sums=('2e66c5fe635cd5dcb9bccca4aced925eca712632b81bada3b63682159c0f910e')
+makedepends=(git)
+options=(!makeflags)
+_tag=0bf0636de624996fe202b51eec8a58abd774269e
+source=(git+https://github.com/manugarg/pacparser.git#tag=$_tag)
+sha256sums=(SKIP)
+
+pkgver() {
+ cd pacparser
+ git describe --tags | sed 's/^v//'
+}
build() {
- cd "pacparser-v${pkgver}"
- PYTHON=python3 make all pymod -C src
+ cd pacparser
+ make all pymod -C src
}
package() {
- cd "pacparser-v${pkgver}"
- PYTHON=python3 make -C src DESTDIR="$pkgdir/" install-pymod
+ cd pacparser
+ make -C src DESTDIR="$pkgdir/" install-pymod
}
# vim:set ts=2 sw=2 et: