summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVictor2023-10-27 16:57:22 +0200
committerVictor2023-10-27 16:57:22 +0200
commit550ce8e927744db17deb3c413a6383bc498d0ae9 (patch)
treebef4b29a0676ca9035545d4a0114de7620944246 /PKGBUILD
parent0eaaf8aa8cd181bfe323821f0c55f1ffdc834d28 (diff)
downloadaur-550ce8e927744db17deb3c413a6383bc498d0ae9.tar.gz
Update to 3.3.3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 51266e57373c..9a68d12eb9bb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,27 +4,27 @@
_name=palettable
pkgname=python-palettable
-pkgver=3.3.2
+pkgver=3.3.3
pkgrel=1
pkgdesc="Color palettes for Python"
arch=('any')
url="https://pypi.org/project/palettable"
license=('MIT')
depends=('python' 'python-matplotlib')
-makedepends=('python-setuptools')
+makedepends=('python-build' 'python-installer' 'python-wheel')
replaces=('python-brewer2mpl')
source=("${pkgname}-${pkgver}.tar.gz::https://pypi.io/packages/source/${_name:0:1}/${_name}/${_name}-${pkgver}.tar.gz"
"https://raw.githubusercontent.com/jiffyclub/palettable/d267e4aa8f746ab800d4998e670d60eca13f32cd/license.txt")
-sha256sums=('6a867c425a2ff288eab4356bedec00de006dee36c99a6147c2e1b05de789ac9f'
+sha256sums=('094dd7d9a5fc1cca4854773e5c1fc6a315b33bd5b3a8f47064928facaf0490a8'
'06982353629cfa6b7b339fa4cfccd6eca5a4434d5caefb7c32e68baa41a1be7c')
build(){
cd "${srcdir}/${_name}-${pkgver}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
- install -Dm644 license.txt "${pkgdir}/usr/share/licenses/${pkgname}/license.txts"
+ install -Dm644 license.txt "${pkgdir}/usr/share/licenses/${pkgname}/license.txt"
cd "${srcdir}/${_name}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ python -m installer --destdir="${pkgdir}" dist/*.whl
}