summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVictor2020-11-14 23:17:01 +0100
committerVictor2020-11-14 23:17:01 +0100
commitaca99803e1bd76aa3a703e390370eef767fe1960 (patch)
tree76897c9fbd5ef7a50d9d9846b08fba22836230b9 /PKGBUILD
parentec568d316c4e188adf5b36b4bca43af13981c114 (diff)
downloadaur-aca99803e1bd76aa3a703e390370eef767fe1960.tar.gz
Update to 3.3.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD59
1 files changed, 18 insertions, 41 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9f7fbb56dbb9..bb2bcdb6d65d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,53 +1,30 @@
-# Maintainer: Clint Valentine <valentine.clint@gmail.com>
-# Contributer: Kyle Meyer <kyle@kyleam.com>
+# Maintainer: Victor <v1c70rp@gmail.com>
+# Contributor: Clint Valentine <valentine.clint@gmail.com>
+# Contributor: Kyle Meyer <kyle@kyleam.com>
_name=palettable
-pkgbase='python-palettable'
-pkgname=('python-palettable' 'python2-palettable')
-pkgver=3.1.1
-pkgrel=2
+pkgname=python-palettable
+pkgver=3.3.0
+pkgrel=1
pkgdesc="Color palettes for Python"
arch=('any')
-url=https://pypi.org/project/palettable
+url="https://pypi.org/project/palettable"
license=('MIT')
-makedepends=(
- 'python' 'python-setuptools'
- 'python2' 'python2-setuptools')
-options=(!emptydirs)
+depends=('python' 'python-matplotlib')
+makedepends=('python-setuptools')
replaces=('python-brewer2mpl')
-source=(
- "${pkgname}"-"${pkgver}".tar.gz::https://pypi.io/packages/source/"${_name:0:1}"/"${_name}"/"${_name}"-"${pkgver}".tar.gz
- https://raw.githubusercontent.com/jiffyclub/palettable/d267e4aa8f746ab800d4998e670d60eca13f32cd/license.txt
-)
-sha256sums=(
- '0685b223a236bb7e2a900ef7a855ccf9a4027361c8acf400f3b350ea51870f80'
- '06982353629cfa6b7b339fa4cfccd6eca5a4434d5caefb7c32e68baa41a1be7c'
-)
-
-prepare() {
- cp -a "${_name}"-"${pkgver}"{,-py2}
-}
+source=("${pkgname}-${pkgver}.tar.gz::https://pypi.io/packages/source/${_name:0:1}/${_name}/${_name}-${pkgver}.tar.gz"
+ "https://raw.githubusercontent.com/jiffyclub/palettable/d267e4aa8f746ab800d4998e670d60eca13f32cd/license.txt")
+sha256sums=('72feca71cf7d79830cd6d9181b02edf227b867d503bec953cf9fa91bf44896bd'
+ '06982353629cfa6b7b339fa4cfccd6eca5a4434d5caefb7c32e68baa41a1be7c')
build(){
- cd "${srcdir}"/"${_name}"-"${pkgver}"
+ cd "${srcdir}/${_name}-${pkgver}"
python setup.py build
-
- cd "${srcdir}"/"${_name}"-"${pkgver}"-py2
- python2 setup.py build
}
-package_python2-palettable() {
- depends=('python2' 'python2-matplotlib')
-
- install -Dm644 license.txt "${pkgdir}"/usr/share/licenses/"${pkgname}"/license.txts
- cd "${_name}"-"${pkgver}"-py2
- python2 setup.py install --root="${pkgdir}"/ --optimize=1 --skip-build
-}
-
-package_python-palettable() {
- depends=('python' 'python-matplotlib')
-
- install -Dm644 license.txt "${pkgdir}"/usr/share/licenses/"${pkgname}"/license.txts
- cd "${_name}"-"${pkgver}"
- python setup.py install --root="${pkgdir}"/ --optimize=1 --skip-build
+package() {
+ install -Dm644 license.txt "${pkgdir}/usr/share/licenses/${pkgname}/license.txts"
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
}