summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorandalenavals2017-12-29 23:26:02 -0500
committerandalenavals2017-12-29 23:26:02 -0500
commitb6fadcee301e0be2dacd3af80b5904ca68115809 (patch)
tree3a75b57517d00dea3f25f3b1708d06d025e7e1f8 /PKGBUILD
downloadaur-b6fadcee301e0be2dacd3af80b5904ca68115809.tar.gz
numpy and cython no included because not sure if they are dependencies
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9308078b7870
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Andres Alejandro Navarro Alsina <aanavarroa@unal.edu.co>
+# Contributor: Tim Jenness
+_pkgname=python-palpy
+pkgname=${_pkgname}-git
+pkgver=pypi.1.8.1.r0.a7ad770
+pkgrel=1
+pkgdesc=" PALpy is a python interface to the PAL positional astronomy library "
+arch=('i686' 'x86_64')
+url="https://github.com/Starlink/palpy"
+license=('GPL')
+depends=('python')
+makedepends=('git' )
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("${_pkgname}::git+${url}")
+md5sums=('SKIP')
+pkgver() {
+ cd "${_pkgname}"
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+build() {
+ cd "${_pkgname}"
+ git submodule init
+ git submodule update
+ python setup.py build
+}
+
+
+package() {
+ cd "${_pkgname}"
+ python setup.py install --root=${pkgdir} --prefix=/usr
+ install -Dm644 COPYING $pkgdir/usr/share/licenses/$pkgname/LICENSE
+
+}