summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorkewl fft2018-02-14 20:43:18 +0000
committerkewl fft2018-02-14 20:43:18 +0000
commitbc008d284c55dd3f27ee2605b3587d7e92f93687 (patch)
treee16e34515658a88d34ad7a2414a956bebc8341d3 /PKGBUILD
downloadaur-bc008d284c55dd3f27ee2605b3587d7e92f93687.tar.gz
v0.14
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..99f2f5051d26
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Kewl <xrjy@nygb.rh.bet(rot13)>
+
+pkgname='python-pandas_market_calendars'
+_pkgname=${pkgname#python-}
+pkgver=0.14
+pkgrel=1
+pkgdesc="Market and exchange trading calendars for pandas"
+arch=('x86_64')
+depends=('python-six' 'python-pytz' 'python-pandas')
+makedepends=('python-setuptools' 'python-six' 'python-pytz' 'python-pandas')
+url="https://github.com/rsheftel/pandas_market_calendars"
+license=('MIT')
+source=("https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz")
+sha256sums=('3b120e85336bc04f773bf271806d7adfb3a19a7f1c4378da2a771083ec5d2af2')
+
+build() {
+ cd $_pkgname-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd $_pkgname-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1
+}