summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCaleb Maclennan2023-05-03 23:49:33 +0300
committerCaleb Maclennan2023-05-03 23:49:33 +0300
commit173aeaedc7761ed666583ce3cf698f3b255bc273 (patch)
tree964061cf446841eb21fb542b9143a5b3c959d3e8 /PKGBUILD
parentb684941373373ad24e0ee88f2423065c5eef69c5 (diff)
downloadaur-173aeaedc7761ed666583ce3cf698f3b255bc273.tar.gz
upgpkg: python-pandoc-include 0.8.7-3
Rebuild for Python 3.11, normalize PEP517 build tooling
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ff3ec80566c7..c548ca0986a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pipname=pandoc-include
pkgname=python-$_pipname
pkgver=0.8.7
-pkgrel=2
+pkgrel=3
pkgdesc='Panflute filter to allow file includes'
arch=(any)
url="https://github.com/DCsunset/$_pipname"
@@ -11,23 +11,24 @@ license=(MIT)
_py_deps=('natsort>=7'
'panflute>=2.0.5')
depends=("${_py_deps[@]/#/python-}")
-makedepends=(python-setuptools)
+makedepends=(python-{build,installer,wheel}
+ python-setuptools)
_archive="$_pipname-$pkgver"
-source=("$_archive.tar.gz::$url/archive/v$pkgver.tar.gz")
+source=("$url/archive/v$pkgver/$_archive.tar.gz")
sha256sums=('af4a8d950713896d5f6bf4f43d51b978a8f4bef842bdd10974f4760e78db8262')
build() {
cd "$_archive"
- python setup.py build
+ python -m build -wn
}
check() {
cd "$_archive"
- python setup.py test
+ python -m unittest discover
}
package() {
cd "$_archive"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer -d "$pkgdir" dist/*.whl
install -Dm0644 -t "$pkgdir/usr/share/doc/$pkgname/" LICENSE
}