summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCaleb Maclennan2022-04-12 15:32:21 +0300
committerCaleb Maclennan2022-04-12 15:32:21 +0300
commitb405e53d1c76810dd3f2eb5f42936a0f5ddb31f5 (patch)
tree5d162678170260d3fe82696f6a272860709e86b3 /PKGBUILD
parent30120c19991accc9f0f4d87deeaf985dfecd0e6f (diff)
downloadaur-b405e53d1c76810dd3f2eb5f42936a0f5ddb31f5.tar.gz
upgpkg: python-panflute 2.1.3-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 10 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 155552c66e0e..266dc2a7065f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pyname=panflute
pkgname=python-$_pyname
pkgver=2.1.3
-pkgrel=1
+pkgrel=2
pkgdesc='A Pythonic alternative to John MacFarlane’s pandocfilters'
arch=(any)
url="https://github.com/sergiocorreia/$_pyname"
@@ -14,33 +14,32 @@ _pydeps=(click
depends=(pandoc
python
"${_pydeps[@]/#/python-}")
-makedepends=(python-setuptools)
+makedepends=(python-{build,installer}
+ python-setuptools
+ python-wheel)
_pycheckdeps=(pandocfilters
+ pytest
pytest-cov)
checkdepends=("${_pycheckdeps[@]/#/python-}")
provides=("pandoc-$_pyname=$pkgver")
conflicts=("pandoc-$_pyname")
replaces=("pandoc-$_pyname")
_archive="$_pyname-$pkgver"
-source=("$_archive.tar.gz::$url/archive/$pkgver.tar.gz")
+source=("$url/archive/$pkgver/$_archive.tar.gz")
sha256sums=('8e49cc658cdcdbfa66aab8a9e48a414d42b924d2aa2cc225d0215f8f9955568f')
-prepare() {
- cd "$_archive"
- sed -i -e '/click/s/<8/<9/' setup.py
-}
-
build() {
cd "$_archive"
- python setup.py build
+ python -m build -wn
}
check() {
cd "$_archive"
- python setup.py test
+ PYTHONPATH="$PWD" pytest \
+ --deselect tests/test_panfl.py::test_pandoc_call
}
package() {
cd "$_archive"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer -d "$pkgdir" dist/*.whl
}