summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCaleb Maclennan2020-02-12 11:16:37 +0300
committerCaleb Maclennan2020-02-12 11:16:37 +0300
commitdfcb78bbfb50f97b6c9972cfee8de66b937d383e (patch)
treec4634b4818eec1115517937a81066bbccf040a88 /PKGBUILD
parentf8499ef8b7e25f23c5e76ffbe36e6bce4c0d870b (diff)
downloadaur-dfcb78bbfb50f97b6c9972cfee8de66b937d383e.tar.gz
Add provides/conflicts with other AUR package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 17 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6fbebc089894..f8cee59ef9cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,27 +2,30 @@
# PKGBUILD generated by pipman
# Python package author: Sergio Correia <sergio.correia@gmail.com>
-_name=panflute
-pkgname=python-$_name
+_pipname=panflute
+pkgname=python-$_pipname
pkgver=1.12.4
-pkgrel=1
-pkgdesc="Pythonic Pandoc filters"
-arch=(any)
-url="https://github.com/sergiocorreia/$_name"
-license=(BSD3)
-makedepends=("python" "python-pip")
-depends=("python-click"
- "python-yaml"
- "python-shutilwhich")
-source=("$pkgname-$pkgver.tar.gz::https://github.com/sergiocorreia/$_name/archive/$pkgver.tar.gz")
+pkgrel=2
+pkgdesc='A Pythonic alternative to John MacFarlane’s pandocfilters'
+arch=('any')
+url="https://github.com/sergiocorreia/$_pipname"
+license=('BSD')
+makedepends=('python-pip')
+depends=('python'
+ 'python-click'
+ 'python-yaml'
+ 'python-shutilwhich')
+provides=('pandoc-panflute')
+conflicts=('pandoc-panflute')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/sergiocorreia/$_pipname/archive/$pkgver.tar.gz")
sha256sums=('92f9f712a54151b07af736b3b6ba1733c3602600c84b4407fdb714272ff92565')
build() {
- cd "$srcdir/$_name-$pkgver"
+ cd "$_name-$pkgver"
python setup.py build
}
package() {
- cd "$srcdir/$_name-$pkgver"
+ cd "$_name-$pkgver"
python setup.py install --root="$pkgdir" --optimize=1
}