summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCaleb Maclennan2023-05-04 11:54:44 +0300
committerCaleb Maclennan2023-05-04 11:54:44 +0300
commitac789a9c56a1202d30e1ddff102a5c3314d725a3 (patch)
treeb6bbb7e145fdd4b33aedcbf87fe4a22e6f089ef5 /PKGBUILD
parentf8e03f700625fca76d1ba576eaa0aae84791e4f2 (diff)
downloadaur-ac789a9c56a1202d30e1ddff102a5c3314d725a3.tar.gz
upgpkg: python-pantable 0.14.2-2
Rebuild for Python 3.11, normalize PEP517 build tooling
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 38470fdb50cb..8cd3de377b1a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_name=pantable
pkgname=python-$_name
pkgver=0.14.2
-pkgrel=1
+pkgrel=2
pkgdesc='CSV Tables in Markdown: Pandoc Filter for CSV Tables'
arch=(any)
url="https://github.com/ickc/$_name"
@@ -13,17 +13,18 @@ _pydeps=(panflute
depends=(pandoc
python
"${_pydeps[@]/#/python-}")
-makedepends=(python-setuptools)
+makedepends=(python-{build,installer,wheel}
+ python-poetry-core)
_archive="$_name-$pkgver"
source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_archive.tar.gz")
sha256sums=('7e0c9b935a08f1eca78d1a4f7bee457dbcc809a0825c0c5ed0113007b7d00810')
build() {
cd "$_archive"
- python setup.py build
+ python -m build -wn
}
package() {
cd "$_archive"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer -d "$pkgdir" dist/*.whl
}