summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJP-Ellis2019-01-17 13:47:53 +1100
committerJP-Ellis2019-01-17 16:57:54 +1100
commit4fa6029ce528a7538fac878f9f56b2d828dd84a0 (patch)
tree2168404c62bc5137eccfaef06f24f9b8f8af83f6 /PKGBUILD
downloadaur-4fa6029ce528a7538fac878f9f56b2d828dd84a0.tar.gz
Initial commit
Signed-off-by: JP-Ellis <josh@jpellis.me>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3eaf395bb6e5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: JP-Ellis <josh@jpellis.me>
+pkgname=python-papis-rofi-git
+_name=${pkgname#python-}
+_name=${_name//-git}
+provides=python-papis-rofi
+pkgver=0.1.1.r1.1aca0dc
+pkgrel=1
+pkgdesc="Create simple GUIs using the Rofi application (fork for papis)"
+arch=('any')
+url="https://pypi.org/project/papis-rofi/"
+license=('GPL')
+depends=('python' 'papis' 'python-papis-python-rofi')
+optdepends=()
+makedepends=('python-setuptools')
+source=(
+ "git+https://github.com/papis/papis-rofi.git"
+)
+sha256sums=('SKIP')
+noextract=()
+
+pkgver() {
+ cd "${srcdir}/${_name}"
+ printf "${pkgver}.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${_name}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_name}"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}
+
+# vim:set ts=2 sw=2 et: