summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChris Severance2020-12-11 18:38:39 -0500
committerChris Severance2020-12-11 18:38:39 -0500
commitebd5126cc0f301ef9aa959df901e8aa40d8319eb (patch)
tree6ca6bc44435c7f3c8ada1820b712a4b4a8c25c3f /PKGBUILD
parentc71c60f90486e7cfbfc525e699d457851227c533 (diff)
downloadaur-ebd5126cc0f301ef9aa959df901e8aa40d8319eb.tar.gz
Update to 0.5.6
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a4a11fe2cf56..87213667f53e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,12 +4,12 @@ set -u
_pyver="python"
_pybase='parse_type'
pkgname="${_pyver}-${_pybase}"
-pkgver='0.5.2'
+pkgver='0.5.6'
pkgrel='1'
pkgdesc='simplifies to build parse types based on the parse module'
arch=('any')
-url="https://pypi.python.org/pypi/${_pybase}/"
-#url="https://github.com/behave/${_pybase}"
+#url="https://pypi.python.org/pypi/${_pybase}/"
+url='https://github.com/jenisys/parse_type'
license=('BSD')
_pydepends=( # See setup.py, README.rst, and requirements.txt for version dependencies
"${_pyver}-parse>=1.6" # COM
@@ -20,9 +20,12 @@ makedepends=("${_pyver}" "${_pyver}-distribute") # same as python-setuptools
_srcdir="${_pybase}-${pkgver}"
#_verwatch=("${url}/releases" "${url#*github.com}/archive/\(.*\)\.tar\.gz" 'l')
#source=("${_pybase}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
-_verwatch=("https://pypi.org/simple/${_pybase//_/-}/" "${_pybase}-\([0-9\.]\+\)\.tar\.gz" 't')
-source=("https://pypi.io/packages/source/${_pybase: 0:1}/${_pybase}/${_pybase}-${pkgver}.tar.gz")
-sha256sums=('7f690b18d35048c15438d6d0571f9045cffbec5907e0b1ccf006f889e3a38c0b')
+#_verwatch=("https://pypi.org/simple/${_pybase//_/-}/" "${_pybase}-\([0-9\.]\+\)\.tar\.gz" 't')
+#source=("https://pypi.io/packages/source/${_pybase: 0:1}/${_pybase}/${_pybase}-${pkgver}.tar.gz")
+source=("${_srcdir}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
+#https://github.com/jenisys/parse_type/archive/v0.5.6.tar.gz
+md5sums=('872136263b915e051115669b4467876e')
+sha256sums=('12b75aa048595457fa5d15558c1a49a688ad4a585d5d1378b1aff4d99fb532ae')
build() {
set -u