summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXZS2016-09-21 20:43:53 +0200
committerXZS2016-09-21 20:43:53 +0200
commit5ad3497edfca64d1d707e5acaa02d0d0fe6d8975 (patch)
tree8237a77bfc8b7529d7a62887c7cc663f683b4f6d /PKGBUILD
parent07d1018e386a52e2463afb433f90a9fcd9e36948 (diff)
downloadaur-5ad3497edfca64d1d707e5acaa02d0d0fe6d8975.tar.gz
support arbitrary integrity checks
The git-makepkg-templates switched to dynamic adaptation to integrity checks chosen in makepkg.conf. [1] The default checksums chosen reflect recommendations from the Arch Linux Wiki and manual pages. [2] [1]: https://github.com/dffischer/git-makepkg-templates/commit/e84d04b [2]: https://aur.archlinux.org/cgit/aur.git/commit/?h=git-makepkg-templates-git&id=c2ccaaa
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d2b470587f46..d656d74b71cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,11 @@ options=(!emptydirs)
makedepends+=('git')
source+=("${_gitname:=${pkgname%-git}}::${_giturl:-git+$url}")
-md5sums+=('SKIP')
+for integ in $(get_integlist)
+do
+ typeset -n array="${integ}sums"
+ array+=('SKIP')
+done
provides+=("$_gitname=$pkgver")
conflicts+=("$_gitname")