summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXZS2016-02-07 16:28:35 +0100
committerXZS2016-02-07 16:28:35 +0100
commit8f88873ab5098f56ea0d57e52285e5cfc41738c5 (patch)
treefedfe5c67365197af488aed1b23968e70d197b39 /PKGBUILD
parent5307e94a6c2753d3645cf06d0c5593cdeceba10f (diff)
downloadaur-8f88873ab5098f56ea0d57e52285e5cfc41738c5.tar.gz
version provided non-git variant
Other packages usually depend on the package without any -git suffix. This makes it possible to als satisfy these dependency requirements when they target specific versions or version ranges.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 479dcd62d11a..d836f5e56b33 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,8 +13,8 @@ options=(!emptydirs)
makedepends+=('git')
source+=("${_gitname:=${pkgname%-git}}::${_giturl:-git+$url}")
md5sums+=('SKIP')
-provides+=($_gitname)
-conflicts+=($_gitname)
+provides+=("$_gitname=$pkgver")
+conflicts+=("$_gitname")
pkgver() {
cd "$_gitname"