summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorViktor Drobot2021-01-27 20:11:47 +0300
committerViktor Drobot2021-01-27 20:11:47 +0300
commit9f18cc64cb379622f8fbc8c11e1ff118f2b6e385 (patch)
tree060b42c6250fa90bb171e32db0ee75e256e10826 /PKGBUILD
parent6324f0d79939fbb7f148786e47bd8650da2e1e29 (diff)
downloadaur-9f18cc64cb379622f8fbc8c11e1ff118f2b6e385.tar.gz
Update 3.1.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 4 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e91c130c296d..4802c3024617 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,28 +2,17 @@
pkgname=python-pdb2pqr
_name=${pkgname#python-}
-pkgver=3.0.1
-pkgrel=3
+pkgver=3.1.0
+pkgrel=1
pkgdesc="Automates many of the common tasks of preparing structures for continuum solvation calculations as well as many other types of biomolecular structure modeling, analysis, and simulation."
arch=(any)
url="http://pypi.python.org/pypi/${_name}"
license=(BSD)
depends=('python>=3.5' 'python-propka>=3.2' 'python-pandas>=1.0' 'python-pytest>=5.4.1')
-makedepends=(patch)
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz"
- "fix_entrypoint.patch"
- "fix_matchedatoms.patch")
-sha256sums=('15ac0ce77dc17fb459092aca12cc7c2c070904f77914f1197282e28f418b6bd0'
- 'bb177e8fb9a31f2486e5682ae97139ebf87948fb4dc33dc892e90ff606df7211'
- '8708438980e5dda5036d2c4fa404d1817104ebbf0443f7798a2698b75a38fe9c')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+sha256sums=('a6f5e2eefbd8bd2a072a89ee4026977de02dadd56e921095afac88d596b63820')
options=(!emptydirs)
-prepare() {
- cd "${srcdir}/${_name}-${pkgver}"
- patch -Np0 -i "${srcdir}/fix_entrypoint.patch"
- patch -Np0 -i "${srcdir}/fix_matchedatoms.patch"
-}
-
build() {
cd "${srcdir}/${_name}-${pkgver}"
python setup.py build