summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRichard Neumann2020-12-02 10:24:47 +0100
committerRichard Neumann2020-12-02 10:25:06 +0100
commit45e5c15263a178a2a076545b5a36f159e5ffbb5f (patch)
treef1e7bd6ec2349ffd576a93bee6ecb58f3e770542 /PKGBUILD
downloadaur-45e5c15263a178a2a076545b5a36f159e5ffbb5f.tar.gz
Initial release to AUR.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..94af5b5eb9d5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Richard Neumann aka. schard <mail at richard dash neumann period de>
+
+_pkgbase='peeweeplus'
+pkgname="python-${_pkgbase}"
+pkgver=1.4.9
+pkgrel=1
+pkgdesc='Practical extension of a small, expressive ORM'
+arch=('any')
+url="https://gitlab.com/HOMEINFO/${_pkgbase}"
+license=('GPLv3')
+depends=('python' 'python-peewee' 'python-timelib' 'python-strflib')
+optdepends=('python-argon2_cffi: for Argon2Field' 'python-authlib: for authlib integration')
+makedepends=('git' 'python' 'python-setuptools' 'python-setuptools-git')
+provides=("python-${_pkgbase}")
+conflicts=("python-${_pkgbase}")
+source=("${_pkgbase}::git+${url}.git#tag=${pkgver}")
+md5sums=('SKIP')
+
+
+package() {
+ cd "${_pkgbase}"
+ python setup.py install --root "${pkgdir}" --optimize=1
+}