summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bershatsky2023-09-15 18:31:46 +0300
committerDaniel Bershatsky2023-09-15 18:31:46 +0300
commit18d7f5554269feae0c84f21c75fb446b8b5b6a4d (patch)
tree4148985de2f14fb7dde976be4b6ad897a6e34a37 /PKGBUILD
parent8ad01f722442ae6e770d38bcc0e4a0220f0c7080 (diff)
downloadaur-18d7f5554269feae0c84f21c75fb446b8b5b6a4d.tar.gz
Bump version to 0.5.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 3 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 229f661190df..93ecc5abf06b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bershatsky <bepshatsky@yandex.ru>
pkgname=python-peft
_pkgname=${pkgname#python-}
-pkgver=0.3.0
+pkgver=0.5.0
pkgrel=1
pkgdesc='State-of-the-art Parameter-Efficient Fine-Tuning.'
arch=('any')
@@ -20,11 +20,10 @@ depends=(
makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
optdepends=()
source=("$_pkgname-$pkgver.tar.gz::https://github.com/huggingface/$_pkgname/archive/refs/tags/v$pkgver.tar.gz")
-sha256sums=()
+sha256sums=('954b86dcf3dad64562ce7b9167485ac42c47fcc668d82ea99874001aa585f53e')
build() {
- cd $_pkgname-$pkgver
- python -m build -n -w
+ python -m build -nw $_pkgname-$pkgver
}
package() {
@@ -33,4 +32,3 @@ package() {
--destdir $pkgdir \
$_pkgname-$pkgver/dist/$_pkgname-$pkgver-py3-*-*.whl
}
-sha256sums=('2e21b0e410af0378ae3b553a47f7477e81e5ec00d9b0473219afbe24aeba9dc5')