summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuis Martinez2022-10-03 22:20:32 -0500
committerLuis Martinez2022-10-03 22:20:32 -0500
commit850862b6e49e7d9607cecb349b42548d3e903275 (patch)
treea2e0f55af7649aa979d81c0931b80bedec82f54d /PKGBUILD
parent8c8ca4fd4f9472f304df867d40d76ecb55f42b55 (diff)
downloadaur-850862b6e49e7d9607cecb349b42548d3e903275.tar.gz
update to 2.1.107
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f4e4985f72f0..49452a9fc65d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
## GPG key: https://github.com/jsirois.gpg
pkgname=python-pex
-pkgver=2.1.104
+pkgver=2.1.107
pkgrel=1
arch=('any')
pkgdesc='Generates executable Python environments'
@@ -22,10 +22,14 @@ source=("$pkgname::git+$url#tag=v$pkgver?signed")
sha256sums=('SKIP')
validpgpkeys=('A1FE765B15233EAD18FA6ABB93E55CB567B5C626')
+prepare() {
+ cd "$pkgname"
+ sed -i '2c\requires = ["flit_core>=2"]' pyproject.toml
+}
+
build() {
cd "$pkgname"
- ## requires python-flit-core>=2,<3
- python -m build --wheel --skip-dependency-check --no-isolation
+ python -m build --wheel --no-isolation
make -C docs man
}