summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuis Martinez2021-10-04 23:29:08 -0500
committerLuis Martinez2021-10-04 23:29:08 -0500
commit4437dc6ed2f19403ff97e82778928b4fe40d63e0 (patch)
treea560d28faebdc13fe58fe18daa53ee40ba256994 /PKGBUILD
parent0209419d0c49248766ff16956c86a2ae0138ab35 (diff)
downloadaur-4437dc6ed2f19403ff97e82778928b4fe40d63e0.tar.gz
update to 0.1.16
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD50
1 files changed, 39 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 08b6aab1d936..980832f53e44 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,49 @@
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+
pkgname=python-pgmpy
-pkgver=0.1.12
+pkgver=0.1.16
pkgrel=1
-pkgdesc="A library for Probabilistic Graphical Models"
-arch=(any)
+pkgdesc="Probabilistic Graphical Model library"
+arch=('any')
url="https://github.com/pgmpy/pgmpy"
license=('MIT')
-makedepends=('python-setuptools')
-depends=('python-networkx' 'python-pandas' 'python-scikit-learn' 'python-pyparsing' 'python-statsmodels' 'python-tqdm' 'python-pyparsing' 'python-pytorch')
-source=("https://pypi.io/packages/source/p/pgmpy/pgmpy-$pkgver.tar.gz")
-sha256sums=('ff5b8b8ef3c22642a499d6b1633035800185de4628fb380f9fb78db08f71b7e4')
+depends=(
+ 'python>=3.7'
+ 'python-joblib'
+ 'python-networkx'
+ 'python-numpy'
+ 'python-pandas'
+ 'python-pyparsing'
+ 'python-scipy'
+ 'python-scikit-learn'
+ 'python-statsmodels'
+ 'python-pytorch'
+ 'python-tqdm')
+makedepends=(
+ 'python-setuptools'
+ 'python-sphinx'
+ 'python-nbsphinx'
+ 'python-sphinx_rtd_theme')
+# checkdepends=('python-pytest' 'python-mock' 'python-daft')
+changelog=CHANGELOG.md
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha256sums=('4bd3b82a65a406e24f82ecffa5eda6ab8133220272a7e5471a134fcb0ec33ee5')
build() {
- cd pgmpy-$pkgver
- python setup.py build
+ cd "pgmpy-$pkgver"
+ python setup.py build
+ cd docs
+ make man BUILDDIR=_build
}
+# check() {
+# cd "pgmpy-$pkgver"
+# pytest
+# }
+
package() {
- cd pgmpy-$pkgver
- python setup.py install --root="$pkgdir/" --optimize=1
+ cd "pgmpy-$pkgver"
+ PYTHONHASHSEED=0 python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm 644 docs/_build/man/pgmpy.1 -t "$pkgdir/usr/share/man/man1/"
}