summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavid Baum2018-10-17 20:29:59 +0200
committerDavid Baum2018-10-17 20:29:59 +0200
commit17c9279f60a7b108ca6544df55e599fb74358c18 (patch)
treeca72cb72b4281d8fef53287839600280e532932c /PKGBUILD
downloadaur-17c9279f60a7b108ca6544df55e599fb74358c18.tar.gz
v1.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4a7db8b3e9c6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: David Baum <david.baum@naraesk.eu>
+pkgname=python-phue
+pkgver=1.0
+pkgrel=1
+pkgdesc="A Philips Hue Python library"
+arch=('any')
+url="https://github.com/studioimaginaire/phue"
+license=('MIT')
+depends=('python')
+makedepends=('python' 'python-pip')
+source=('LICENSE')
+md5sums=('852ebbd5fd0880fc619e859b04cf2b6c')
+
+build() {
+ pip install --no-deps --target="phue" phue
+}
+package() {
+ mkdir -p $pkgdir/usr/lib/python3.7/site-packages/
+ cp -r $srcdir/phue/* $pkgdir/usr/lib/python3.7/site-packages/
+ install -Dm644 $srcdir/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}