summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMaximilian Stahlberg2020-09-27 15:31:30 +0200
committerMaximilian Stahlberg2020-09-27 15:31:30 +0200
commit2a4d9e2187fc25ff18e762047bc08db587efdb7b (patch)
tree83f07bc7d1175ec5217b599d711d1f5c371b4d34 /PKGBUILD
parent0502d6862f188c7a866c6ca4b002ee0a6bcfd9c7 (diff)
downloadaur-2a4d9e2187fc25ff18e762047bc08db587efdb7b.tar.gz
Add optional dependencies.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 10 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9eab64c3e5f7..33f0df28b2e2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,21 @@
pkgname=python-picos
pkgver=2.0
-pkgrel=2
+pkgrel=3
pkgdesc='A Python interface to conic optimization solvers.'
arch=('any')
url='https://gitlab.com/picos-api/picos'
license=('GPL3')
depends=('python-numpy' 'python-cvxopt')
+optdepends=(
+ 'cplex: solve using CPLEX'
+ 'gurobi: solve using Gurobi'
+ 'mosek: solve using MOSEK'
+ 'python-ecos: solve using ECOS'
+ 'python-pyscipopt: solve using SCIP'
+ 'python-smcp: solve using SMCP'
+ 'python-swiglpk: solve using GLPK'
+)
makedepends=('python-setuptools')
conflicts=('python-picos-git')
source=("https://gitlab.com/picos-api/picos/-/archive/v${pkgver}/picos-v${pkgver}.tar.gz")