summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMaximilian Stahlberg2017-10-19 20:32:54 +0200
committerMaximilian Stahlberg2017-10-19 20:32:54 +0200
commit3b3a947b471fcdadc43a356847a1b5135ae88e3b (patch)
tree9d4bfc24164e24a9e60b6ba24e756ca281ec056c /PKGBUILD
downloadaur-3b3a947b471fcdadc43a356847a1b5135ae88e3b.tar.gz
Initial package for PICOS 1.1.2.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..808458b53139
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Maximilian Stahlberg <maximilian.stahlberg tu-berlin de>
+
+pkgbase=('python-picos')
+pkgname=('python-picos' 'python2-picos')
+pkgver=1.1.2
+pkgrel=1
+pkgdesc='A Python Interface for Conic Optimization Solvers.'
+arch=('any')
+url='http://picos.zib.de'
+license=('GPL3')
+source=("http://picos.zib.de/dist/PICOS-${pkgver}.tar.gz")
+
+package_python-picos() {
+ makedepends=('python-setuptools')
+ depends=('python-six' 'python-numpy' 'python-cvxopt')
+
+ cd "${srcdir}/PICOS-${pkgver}"
+
+ python setup.py install --root=${pkgdir}
+}
+
+package_python2-picos() {
+ makedepends=('python2-setuptools')
+ depends=('python2-six' 'python2-numpy' 'python2-cvxopt')
+
+ cd "${srcdir}/PICOS-${pkgver}"
+
+ python2 setup.py install --root=${pkgdir}
+}
+
+md5sums=('e5f7996a70b9ee5bbc5f28347c52a2df')