summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorClaudia Pellegrino2021-11-23 12:27:57 +0100
committerClaudia Pellegrino2021-11-23 12:27:57 +0100
commit9b25f853bb2d2dea889ae9e3db5834dd4ce59b9b (patch)
tree1d46cf9a54c18973407935a7723c292277fbe2be /PKGBUILD
parent84f70b830da9d5d0555e5220ee0a0d7a1871a3e6 (diff)
downloadaur-9b25f853bb2d2dea889ae9e3db5834dd4ce59b9b.tar.gz
Update dependencies
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 21 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d99f6176c958..255395f9af0b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,32 @@
pkgname=python-pip-audit-git
_gitpkgname=pip-audit
-pkgver=r61.844c85f
+pkgver=r98.1c69d2d
pkgrel=1
pkgdesc='A tool for scanning Python environments for known vulnerabilities'
arch=('any')
url='https://github.com/trailofbits/pip-audit'
license=('Apache')
-depends=('python-pip-api' 'python-packaging' 'python-dataclasses' 'python-progress' 'python-resolvelib' 'python-html5lib' 'python-cachecontrol' 'python-lockfile')
+depends=(
+ # Upstream requires pip-api >= 0.0.23 but Arch’s Community
+ # repository is on 0.0.18, which causes an error message that
+ # says “failed to list installed distributions.”
+ # Once community/python-pip-api catches up to version 0.0.23,
+ # remove the `>=0.0.23` part from the following line.
+ 'python-pip-api>=0.0.23'
+ 'python-packaging'
+ 'python-dataclasses'
+ 'python-progress'
+ # Upstream requires resolvelib >=0.8.0, but extra/python-resolvelib
+ # is at 0.5.5 (possibly for compatibility with extra/python-pip
+ # 20.3.4). The 0.5.5 version appears to work just fine, so let’s
+ # ignore the mismatch.
+ 'python-resolvelib'
+ 'python-html5lib'
+ 'python-cachecontrol'
+ 'python-lockfile'
+ 'python-cyclonedx-lib'
+)
makedepends=('git' 'python-setuptools')
conflicts=('python-pip-audit')
options=('!strip')