summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFabian Maurer2024-03-07 20:15:29 +0100
committerFabian Maurer2024-03-07 20:15:29 +0100
commit7b905417b054acb5fea19bb4ff6bfec8be6109c6 (patch)
treed0998afda102ff32500e5cef0daa98e7a7cb90c5 /PKGBUILD
parent36b91c8f3a26d721659c19962e49feb6d710395e (diff)
downloadaur-7b905417b054acb5fea19bb4ff6bfec8be6109c6.tar.gz
Use recommended way to build package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a6d1beb94b38..4e0fb7c489fa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,23 @@
pkgname=python-pip-system-certs
pkgver=4.0
-pkgrel=1
+pkgrel=2
pkgdesc="Patches pip and requests at runtime to use certificates from the default system store"
arch=('any')
license=('BSD')
url="https://gitlab.com/alelec/pip-system-certs"
depends=('python3')
-makedepends=('python-setuptools')
+makedepends=(python-build python-installer python-wheel python-git-versioner)
source=("https://gitlab.com/alelec/pip-system-certs/-/archive/v4.0/pip-system-certs-v$pkgver.tar.gz")
sha512sums=('6c583e0f8b61a774a78e0f561aa95717ed3e5735268bdd6a2767f0803697a3f7a64d132c9d1d5947a2bf06c220b9da4a10d4c31e8e523605422c4cbb7935a294')
build() {
+ export SETUPTOOLS_SCM_PRETEND_VERSION=$pgkver
cd pip-system-certs-v$pkgver
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd pip-system-certs-v$pkgver
- python setup.py install --root="$pkgdir" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
}