summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuis Martinez2021-10-14 23:48:53 -0500
committerLuis Martinez2021-10-14 23:48:53 -0500
commit482367a5e207f2e3a9f2c8d14e9cf7f9292708a7 (patch)
tree0b109455018b4c4159d0d4260df730fe2328edb0 /PKGBUILD
parent301c1841b5785848310bfb1bd570978c3d3e2117 (diff)
downloadaur-482367a5e207f2e3a9f2c8d14e9cf7f9292708a7.tar.gz
update to 1.0.0
* package cleaned up according to Python packaging guidelines * target tag 1.0.0 instead of master branch * use python-setuptools for packaging
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD60
1 files changed, 19 insertions, 41 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 332354240a87..2d4195ec1ae2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,55 +1,33 @@
-# This is an example PKGBUILD file. Use this as a start to creating your own,
-# and remove these comments. For more information, see 'man PKGBUILD'.
-# NOTE: Please fill out the license field for your package! If it is unknown,
-# then please put 'unknown'.
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: Andres Alejandro Navarro Alsina <aanavarroa@unal.edu.co>
+# Contributor: G. Bernstein, M. Jarvis and E. Sheldon
-# Maintainer: Andres Alejandro Navarro Alsina <aanavarroa@unal.edu.co>
-# Contributor: G. Bernstein, M. Jarvis and E. Sheldon
pkgname=python-pixmappy
-pkgver=r40.5c82c73
+pkgver=1.0.0
pkgrel=1
-#epoch=
-
pkgdesc=" Python interface to gbdes pixel map (astrometry) solutions "
-
-
arch=('any')
url="https://github.com/gbernstein/pixmappy"
license=('BSD')
-groups=()
-depends=('python-numpy' 'python-future' 'python-astropy' 'python-scipy' 'python-yaml')
-makedepends=('git')
-checkdepends=()
-optdepends=()
-#provides=()
-#conflicts=()
-#replaces=()
-#backup=()
-options=()
-install=
-changelog=
-source=("$pkgname-$pkgver::git+${url}")
-#noextract=()
-md5sums=('SKIP')
-#validpgpkeys=()
-
+depends=(
+ 'python-numpy'
+ 'python-future'
+ 'python-astropy'
+ 'python-scipy'
+ 'python-yaml'
+ 'python-coord')
+makedepends=('python-setuptools')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha256sums=('9ef1ddeaea58ca50cbf7226a2c68ac183726ae3e97028f9011849dd086f7c48d')
build() {
- cd "$src"
- cd "$pkgname-$pkgver"
+ cd "pixmappy-$pkgver"
python setup.py build
}
-
-pkgver() {
- cd "$pkgname-$pkgver"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
-
-
package() {
- cd "$src"
- cd "$pkgname-$pkgver"
- python setup.py install --root=${pkgdir} --prefix=/usr
-
+ cd "pixmappy-$pkgver"
+ PYTHONHASHSEED=0 python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm 644 Piff_LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
}