summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authortrougnouf2018-09-20 13:31:23 +0200
committertrougnouf2018-09-20 13:31:23 +0200
commitb99942c5d03a5290a1ff615da9d19cf2a9b25f8f (patch)
treeade819cd1a5f610fd1ef694fcd6ae3a61d5f2015 /PKGBUILD
downloadaur-b99942c5d03a5290a1ff615da9d19cf2a9b25f8f.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..751abea045fa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: trougnouf (Benoit Brummer) < trougnouf at gmail dot com >
+
+pkgname='python-plaidml'
+_name='plaidml'
+pkgver=0.3.5
+pkgrel=1
+pkgdesc='PlaidML machine learning accelerator'
+url="https://github.com/${_name}/${_name}"
+depends=('python-numpy' 'python-requests' 'python-six')
+license=('AGPL3')
+arch=('x86_64')
+source=("https://files.pythonhosted.org/packages/py2.py3/${_name::1}/${_name}/${_name}-$pkgver-py2.py3-none-manylinux1_x86_64.whl")
+sha256sums=('7df944bdde540fe11e4ec00a402f10a93ed57b0faaf6cb7311acacbf86e955fc')
+
+package() {
+ PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps --no-warn-script-location *.whl
+ rm -R $pkgdir/usr/lib/python*/site-packages/plaidml-*
+}
+