summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAleksandar Trifunovic2018-08-22 12:22:53 +0200
committerAleksandar Trifunovic2018-08-22 12:22:53 +0200
commit5010b245be5b9e8c044c602686dd5af14172214d (patch)
treee835abeecc8f86d9f42d3f94348aef69a7de689a /PKGBUILD
downloadaur-5010b245be5b9e8c044c602686dd5af14172214d.tar.gz
v0.6
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9720238df87d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Aleksandar Trifunović <akstrfn at gmail dot com>
+
+pkgname=python-plaster-pastedeploy
+pkgver=0.6
+_distname=plaster_pastedeploy-$pkgver
+pkgrel=2
+pkgdesc="A loader interface around multiple config file formats."
+arch=('any')
+url="https://github.com/Pylons/plaster_pastedeploy"
+license=('MIT')
+depends=('python-plaster' 'python-pastedeploy')
+makedepends=('python-setuptools')
+checkdepends=('python-pytest-runner')
+source=("$url/archive/$pkgver.tar.gz")
+sha256sums=('6259d32c427bec456b0179835cba35ebb42dd171701d8cc4974ce386cf595bdd')
+
+build(){
+ cd $_distname
+ python setup.py build
+}
+
+check(){
+ cd $_distname
+ python setup.py pytest -v
+}
+
+package(){
+ cd $_distname
+ python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
+ install -D LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}