summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFernando Cladera2015-12-07 11:55:43 -0300
committerFernando Cladera2015-12-07 11:55:43 -0300
commit1297e923a7419c615b3dd984057540ef6edabf2b (patch)
treecd7273dc4cc2b372c481d5e691912b797665239d /PKGBUILD
downloadaur-1297e923a7419c615b3dd984057540ef6edabf2b.tar.gz
Initial build
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..77f2dd521951
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: fclad <fcladera at fcladera.com>
+
+_pkgname=plotly.py
+pkgname=python-plotly
+pkgver=1.6.12.r715.g20102d6
+pkgrel=1
+pkgdesc="An interactive, browser-based charting library for python"
+arch=('i686' 'x86_64')
+url="https://plot.ly/python/"
+license=('MIT')
+depends=('python-requests' 'python-pytz')
+makedepends=('git' 'python')
+source=("git+https://github.com/plotly/plotly.py.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+
+ #[ -d build ] && rm -rf build
+ #mkdir build
+ #cd build
+
+ #python config.py -auto
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ python setup.py install --root="${pkgdir}" --prefix=/usr
+}