summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFernando Cladera2016-04-19 11:42:25 -0300
committerFernando Cladera2016-04-19 11:46:00 -0300
commit48fb80d6507f35ee742b9391cb76c9c10a3dc73d (patch)
treed06fdf3e2b21910884eb15f050f340667b2e9155 /PKGBUILD
parent8dc439693e9b705347fabd3b57bfc2f03dac31f8 (diff)
downloadaur-48fb80d6507f35ee742b9391cb76c9c10a3dc73d.tar.gz
Use revision number instead of tags to get the revision
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6f5ff23f1550..04618708e263 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=plotly.py
pkgname=python-plotly
-pkgver=1.6.12.r715.g20102d6
+pkgver=r1780.d88c5d0
pkgrel=1
pkgdesc="An interactive, browser-based charting library for python"
arch=('i686' 'x86_64')
@@ -14,8 +14,8 @@ source=("git+https://github.com/plotly/plotly.py.git")
md5sums=('SKIP')
pkgver() {
- cd "$srcdir/$_pkgname"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "$srcdir/$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {