summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authornickcorona2019-03-25 20:38:50 -0400
committernickcorona2019-03-25 20:38:50 -0400
commit1d13542e971f489542f2a7294f3e9edbc4542c21 (patch)
treec255928e3837198e4a77985e09e04b5f64911d97 /PKGBUILD
downloadaur-1d13542e971f489542f2a7294f3e9edbc4542c21.tar.gz
Plotly Express is a terse, consistent, high-level wrapper around Plotly.py for rapid data exploration and figure generation.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 18 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..46fa4b000fcf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# PKGBUILD generated by pipman
+# Python package author: Nicolas Kruchten <nicolas@plot.ly>
+pkgname=python-plotly_express
+pkgver=0.1.1
+pkgrel=1
+pkgdesc="Plotly Express: a high level wrapper for Plotly.py"
+arch=(any)
+url="https://github.com/plotly/plotly_express"
+license=(UNKNOWN)
+makedepends=("python" "python-pip")
+build() {
+ pip install --no-deps --target="plotly_express" plotly_express==0.1.1
+}
+package() {
+ sitepackages=$(python -c "import site; print(site.getsitepackages()[0])")
+ mkdir -p $pkgdir/"$sitepackages"
+ cp -r $srcdir/plotly_express/* $pkgdir/"$sitepackages"
+} \ No newline at end of file