summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhilipp A2019-10-15 14:17:54 +0200
committerPhilipp A2019-10-15 14:17:54 +0200
commitb5aee37f3625e9aa85dd964aee0c64a68d8d89d6 (patch)
treeb309c00bd4aa2619ce9f0c3ccf3645497ade1458 /PKGBUILD
parentfcea5697a109ddc1a173a9640215014a9ef6deda (diff)
downloadaur-b5aee37f3625e9aa85dd964aee0c64a68d8d89d6.tar.gz
no pip
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bc11c0405c36..325040ba95cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
_name=plotnine
pkgname=python-$_name
pkgver=0.6.0
-pkgrel=1
+pkgrel=2
pkgdesc='A grammar of graphics for python'
arch=(any)
url="https://github.com/has2k1/$_name"
@@ -17,7 +17,6 @@ depends=(
'python-pandas>=0.23.4'
'python-descartes>=1.1.0'
)
-makedepends=(python-pip)
optdepends=(
'python-scikit-learn: gaussian process smoothing, kernel density implementation'
'python-scikit-misc: loess smooting'
@@ -29,5 +28,7 @@ noextract=("$_wheel")
sha256sums=('c271d08edf276f6be09951a4544a1116fc7aa6bc68cadef1b05e29c26ff5f683')
package() {
- pip install --compile --no-deps --ignore-installed --root="$pkgdir" "$_wheel"
+ local site="$pkgdir/usr/lib/$(readlink /bin/python3)/site-packages"
+ mkdir -p "$site"
+ unzip "$_wheel" -d "$site"
}