summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhilipp A2018-11-23 15:04:52 +0100
committerPhilipp A2018-11-23 15:04:52 +0100
commitf691fccd65b770f372acbf433758a0734ce76edc (patch)
treeb7b8af68508052ca16a86756153b2d9f09309c35 /PKGBUILD
parentdc8850df1261b39a8e23fed63d84c0f7046cb6ac (diff)
downloadaur-f691fccd65b770f372acbf433758a0734ce76edc.tar.gz
v0.5.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 11 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 23c5b8736188..0b6c48975795 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
_name=plotnine
pkgname=python-$_name
-pkgver=0.3.0
+pkgver=0.5.1
pkgrel=1
pkgdesc='A grammar of graphics for python'
arch=(any)
@@ -8,20 +8,24 @@ url="https://github.com/has2k1/$_name"
license=(GPL2)
depends=(
python
+ 'python-mizani>=0.5.2'
+ 'python-matplotlib>=3.0.0'
python-numpy
- python-six
- 'python-matplotlib>=2.1.0'
- 'python-mizani>=0.4.1'
- 'python-pandas>=0.21.0'
- 'python-patsy>=0.4.1'
'python-scipy>=1.0.0'
+ 'python-patsy>=0.4.1'
'python-statsmodels>=0.8.0'
+ 'python-pandas>=0.23.4'
+ 'python-descartes>=1.1.0'
)
makedepends=(python-pip)
+optdepends=(
+ 'python-scikit-learn: gaussian process smoothing, kernel density implementation'
+ 'python-scikit-misc: loess smooting'
+)
_wheel="$_name-$pkgver-py2.py3-none-any.whl"
source=("https://files.pythonhosted.org/packages/py2.py3/${_name::1}/$_name/$_wheel")
noextract=("$_wheel")
-sha256sums=('ed18a7e9f30b685f383f252dd844492a667cc567d06ebf5e9688b941316161ca')
+sha256sums=('0d8b44a6e433a9303231f2d402c5b898f50c04809a2fee8e393dc79a2d8d762d')
package() {
pip install --compile --no-deps --ignore-installed --root="$pkgdir" "$_wheel"