summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTomislav Ivek2020-12-04 11:57:22 +0100
committerTomislav Ivek2020-12-04 11:57:22 +0100
commit2ebca92da2e8feca907cb4a76357b0e5b37a6d43 (patch)
treeac4a7494f3499d90d342f9d98a949b4ebcc6c48d /PKGBUILD
parentb9451328ee7f8f34f55725f6a0251068bfc16a56 (diff)
downloadaur-2ebca92da2e8feca907cb4a76357b0e5b37a6d43.tar.gz
remove Python 2 support
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 4 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 852956544a17..620e8a2acb43 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,33 +4,25 @@
_name="pluginbase"
_module="$_name"
-pkgname=("python-$_module" "python2-$_module")
+pkgname=("python-$_module")
pkgver=1.0.0
-pkgrel=3
+pkgrel=4
pkgdesc="A support library for building plugins systems in Python."
arch=("any")
url="http://pluginbase.pocoo.org/"
license=("BSD")
-makedepends=("python-setuptools" "python2-setuptools" "fakeroot")
+makedepends=("python-setuptools")
+depends=("python")
source=("https://github.com/mitsuhiko/pluginbase/archive/$pkgver.tar.gz")
sha256sums=('ab0e5fc405f1d28abe99724943ad54b5e7fb1c2f6b1519f0942e2074e6c8c22a')
build() {
cd "$_name-$pkgver"
python setup.py build
- python2 setup.py build
}
package_python-pluginbase() {
- depends=("python")
cd "$_name-$pkgver"
python setup.py install --skip-build --root="$pkgdir" --optimize=1
install -D --mode 644 --target-directory "$pkgdir/usr/share/licenses/$pkgname" LICENSE
}
-
-package_python2-pluginbase() {
- depends=("python2")
- cd "$_name-$pkgver"
- python2 setup.py install --skip-build --root="$pkgdir" --optimize=1
- install -D --mode 644 --target-directory "$pkgdir/usr/share/licenses/$pkgname" LICENSE
-}