summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCaleb Maclennan2023-03-17 01:39:31 +0300
committerCaleb Maclennan2023-03-17 01:39:31 +0300
commit863b9cc5b53c1415feb2d7dd813e31a4bf5a657a (patch)
treec0c42d4dbbf8e296a84c294070efaf98f1728a28 /PKGBUILD
parent2c43e158941fdc5378afd0fe9a110499c3c8836b (diff)
downloadaur-863b9cc5b53c1415feb2d7dd813e31a4bf5a657a.tar.gz
upgpkg: python-plum 0.8.5-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c866067da462..95cf96a4f103 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,19 +3,23 @@
_pyname=plum
pkgname=python-${_pyname,,}
pkgver=0.8.5
-pkgrel=1
+pkgrel=2
pkgdesc='Pack/Unpack Memory'
arch=(any)
url="https://$_pyname-py.readthedocs.io/en/latest/"
license=(MIT)
depends=(python)
-makedepends=(python-{build,installer}
- python-setuptools
- python-wheel)
+makedepends=(python-{build,installer,wheel}
+ python-setuptools)
_archive="$_pyname-$pkgver"
source=("https://gitlab.com/dangass/$_pyname/-/archive/$pkgver/$_archive.tar.bz2")
sha256sums=('41016eed6cdbe1429afc21654cd05f935fc13ae8eb465981f6c3b1e92c57319e')
+prepare() {
+ cd "$_archive"
+ sed -i -e '/python_requires/d' setup.cfg
+}
+
build() {
cd "$_archive"
python -m build -wn