summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEndlessEden2021-08-21 14:13:43 +1000
committerEndlessEden2021-08-21 14:13:43 +1000
commit4b208882bf55ef9028ae7665aebf9f1816801ac6 (patch)
treee5fd86360af679ff9cb8979c0f43f096a448a420 /PKGBUILD
parent21e2f46e59716ceafa3a09b518e4479571752942 (diff)
downloadaur-4b208882bf55ef9028ae7665aebf9f1816801ac6.tar.gz
Updated: added missing depends, cleaned up slightly. Will improve more at a later date.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 50b2d79f46aa..9c89100b54f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,11 +7,11 @@ pkgname=('python-pocketsphinx-git' 'python2-pocketsphinx-git' 'sphinxbase-git' '
pkgver=r185.769492d
pkgrel=2
pkgdesc='Python interface to CMU SphinxBase and PocketSphinx libraries'
-arch=('i686' 'x86_64')
+arch=('i386' 'i686' 'pentium4' 'core2' 'x86_64')
url='https://github.com/bambocher/pocketsphinx-python'
license=('BSD')
-depends=('python' 'swig')
-makedepends=('git' 'python' 'python2')
+depends=('python' 'swig' 'python-setuptools' 'python2-setuptools')
+makedepends=('git' 'python' 'python2' 'bison')
# The Python bindings to pocketsphinx are made by bambocher. Dependencies are
# stored as git submodules and are maintained by the CMU Sphinx project.
source=(
@@ -33,7 +33,7 @@ prepare() {
git submodule init
git config submodule.deps/pocketsphinx.url ${srcdir}/pocketsphinx
git config submodule.deps/sphinxbase.url ${srcdir}/sphinxbase
- git submodule update
+ git submodule update --remote
# We want a python2 package as well. Let's copy the sources.
cd "${srcdir}"