summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2023-02-12 16:20:18 -0500
committerCarlos Aznarán Laos2023-02-12 16:20:18 -0500
commit37d80d29f671fd193c3f95238a812549e8eb3b96 (patch)
tree414411abbca1dcbba5e6efd8b6d6fec6e50d98be /PKGBUILD
parenta12e2b04f2dea612d4da861d608b411f387ca62b (diff)
downloadaur-python-poetry-git.tar.gz
Add depedency
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4435f246d19c..dab9ebd9c2a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,11 +6,11 @@ pkgver=1.2.0b1.r82.gedabfce1
pkgrel=1
pkgdesc="Python dependency management and packaging made easy"
arch=(any)
-url="https://python-poetry.org"
+url="https://python-${_pkgname}.org"
license=(MIT)
_deps=(cachecontrol
- cachy
- cleo-git
+ cleo
+ crashtest
dulwich
html5lib
keyring
@@ -18,17 +18,19 @@ _deps=(cachecontrol
packaging
pexpect
pkginfo
+ platformdirs
poetry-core-git
+ poetry-plugin-export
requests
requests-toolbelt
shellingham
tomlkit
- virtualenv)
+ urllib3
+ trove-classifiers
+ virtualenv) # cachy pyprojects-hook
depends=("${_deps[@]/#/python-}")
makedepends=(python-{build,installer} git)
-checkdepends=(python-httpretty
- python-pytest
- python-pytest-mock)
+# checkdepends=(python-httpretty python-pytest python-pytest-mock)
provides=(poetry python-poetry)
conflicts=(poetry python-poetry)
source=(git+https://github.com/python-${_pkgname}/${_pkgname}.git