summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorUniversebenzene2022-02-27 21:27:53 +0800
committerUniversebenzene2022-02-27 21:27:53 +0800
commit0cd37eab298177af1ecfe4a96e07d3e75950e67f (patch)
treeef42fe7394f46123aa75c95735bbf64d3ca2c0f3 /PKGBUILD
parent99d4f23439695345808698995ce4082ebd875567 (diff)
downloadaur-0cd37eab298177af1ecfe4a96e07d3e75950e67f.tar.gz
Update to version 0.16.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 6 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2b570690d07c..7e97b5f3ad4e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
pkgname=python-poliastro
_pyname=${pkgname#python-}
-pkgver=0.16.0
+pkgver=0.16.2
pkgrel=1
pkgdesc="Astrodynamics and Orbital Mechanics computations"
arch=('any')
url="http://docs.poliastro.space"
license=('MIT')
-makedepends=('python-setuptools' 'python-dephell')
+makedepends=('python-flit-core' 'python-wheel' 'python-build' 'python-installer' 'python-oldest-supported-numpy')
#checkdepends=('python-pytest'
# 'python-wheel'
# 'python-hypothesis'
@@ -21,18 +21,12 @@ makedepends=('python-setuptools' 'python-dephell')
# 'python-jplephem'
# 'python-numba')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('37e9d40c6190e8ca765c57adb727d176')
-
-prepare() {
- cd ${srcdir}/${_pyname}-${pkgver}
-
- dephell deps convert --from pyproject.toml --to setup.py
-}
+md5sums=('c7c32e6bad2b913f66a2a50491a72704')
build() {
cd ${srcdir}/${_pyname}-${pkgver}
- python setup.py build
+ python -m build --wheel --no-isolation
}
#check() {
@@ -43,16 +37,13 @@ build() {
#}
package() {
- depends=('python-scipy' 'python-astropy' 'python-jplephem' 'python-matplotlib>3.0.1' 'python-plotly' 'python-numba>=0.53.0')
- #'python-retrying')
+ depends=('python-scipy>=1.4.0' 'python-astroquery>=0.3.9"' 'python-jplephem' 'python-matplotlib>3.0.1' 'python-plotly<6' 'python-numba>=0.53.0' 'python-pyerfa' 'python-pandas')
optdepends=('python-poliastro-doc: Documentation for poliastro'
# 'python-numba: For accelerating the code'
- 'python-pandas'
- 'python-astroquery>=0.3.9'
'python-pytest: For running the tests from the package')
cd ${srcdir}/${_pyname}-${pkgver}
install -D -m644 COPYING -t "${pkgdir}/usr/share/licenses/${pkgname}"
install -D -m644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
- python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
+ python -m installer --destdir="${pkgdir}" dist/*.whl
}