summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoradrien10182019-10-16 13:10:49 +0800
committeradrien10182019-10-16 13:10:49 +0800
commitac252e79f28d65586b7dcd3ff7fd954c89d81090 (patch)
treee80066033c2874920edb15e0c665f542bdd2f184 /PKGBUILD
downloadaur-ac252e79f28d65586b7dcd3ff7fd954c89d81090.tar.gz
First commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4249b04e7fe0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Adrien Wu <adrien.sf.wu@gmail.com>
+pkgname=python-polyglot
+pkgver=16.7.4
+pkgrel=1
+pkgdesc="A natural language pipeline that supports massive multilingual applications"
+url="https://github.com/aboSamoor/polyglot"
+arch=('any')
+provides=('python-polyglot')
+makedepends=('python-setuptools')
+_name="${pkgname#python-}"
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('f7d9cca9a212622548e9416fb89f1238b994b8860ef49e03b7c82c67f9b6269b')
+
+build() {
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}