summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJan Sandberg2019-05-02 10:14:26 +0200
committerJan Sandberg2019-05-02 10:39:06 +0200
commit2ac9ecbf0352bdeaaebecc1851cfbb3b632e739f (patch)
treec958f013f2e3bf7bc3a79a8158ffd2b967a1c32b /PKGBUILD
downloadaur-2ac9ecbf0352bdeaaebecc1851cfbb3b632e739f.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a5ade3efd8ef
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Jan Sandberg <jan dot sandberg at gmx dot ch>
+
+pkgname=python-poxls-git
+conflicts=('python-poxls')
+provides=('python-poxls')
+_pkgname=poxls
+pkgver=1.4.2.r1.g24b7c5c
+pkgrel=1
+pkgdesc='Convert between Excel and PO files'
+url='https://pypi.python.org/pypi/poxls'
+arch=('any')
+license=('BSD')
+_deps=('click' 'openpyxl' 'polib')
+makedepends=('git' 'python-setuptools')
+depends=("${_deps[@]/#/python-}")
+source=("poxls::git+https://github.com/wichert/po-xls.git"
+ "LICENSE")
+sha256sums=('SKIP'
+ 'c909022c938835ff0a322a536315c193732bcd308bae4538fc81cc21896230e1')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long --tags | sed 's:^release/::;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ python setup.py build
+}
+
+package_python-poxls-git() {
+ depends=('python' "${_deps[@]/#/python-}")
+ cd "${srcdir}/${_pkgname}"
+ python setup.py install --skip-build --root="${pkgdir}" --optimize=1
+ install -D -m644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}