summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjerry732042019-06-24 00:23:06 +0800
committerjerry732042019-06-24 00:23:06 +0800
commit72733bcf8d0398449c0eef1d49fdad9197913bb1 (patch)
tree79b0bdc4c633f6c6e0d83ee657d8c687623a23fa /PKGBUILD
downloadaur-72733bcf8d0398449c0eef1d49fdad9197913bb1.tar.gz
Bump to 1.0-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3fdd9f1c8b90
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Jerry Lin <jerry73204 at gmail dot com>
+
+pkgname='python-pqdict'
+pkgver=1.0
+pkgrel=1
+pkgdesc='A Pythonic indexed priority queue'
+arch=('x86_64')
+url="https://github.com/nvictus/priority-queue-dictionary"
+license=('MIT')
+makedepends=('python-setuptools')
+source=("https://github.com/nvictus/priority-queue-dictionary/archive/v${pkgver}.tar.gz")
+sha256sums=('811f3912a7ffe36d37b973f57eb0ef9c5abcf0407d22325a2bed0653e1a5766c')
+
+_dirname="priority-queue-dictionary-${pkgver}"
+
+build() {
+ cd "${srcdir}/${_dirname}"
+ python setup.py build
+}
+
+package() {
+ depends=('python' 'kafka')
+ cd "${srcdir}/${_dirname}"
+ python setup.py install --root="$pkgdir" --optimize=1
+}